summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWilliam Gathoye2017-07-04 20:03:49 +0200
committerWilliam Gathoye2017-07-04 20:04:39 +0200
commit7882ae86382af473724413e29a6cf8a5f715319a (patch)
tree27fefde9ea02ef2cdfa4e61f8945896131dbdbd6 /PKGBUILD
parentbeb4129f8538780f51e5d272b10b4396710bb567 (diff)
downloadaur-7882ae86382af473724413e29a6cf8a5f715319a.tar.gz
Upgrade to 0.5.17.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 19 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5da58b4224f2..a33b59179516 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,33 @@
-# Maintainer: Hyacinthe Cartiaux <hyacinthe.cartiaux@free.fr>
-# Contributor: <gilrain+libre.arch A_T castelmo DOT_ re>
+# Maintainer: Hyacinthe Cartiaux <hyacinthe dot cartiaux at free dot fr>
+# Maintainer: William Gathoye <william + aur at gathoye dot be>
+# Contributor: <gilrain + libre dot arch at castelmo dot re>
pkgname=libreoffice-extension-grammalecte-fr
-pkgver=0.5.17.1
+pkgver=0.5.17.2
pkgrel=1
pkgdesc="French grammar checker extension for LibreOffice."
arch=('any')
+
url="http://www.dicollecte.org/grammalecte/"
-license=('GPL3' 'custom:MPL2' 'LGPL')
+license=('GPL3')
+
depends=('libreoffice')
+makedepends=('unzip')
groups=('libreoffice-extensions')
+
conflicts=('libreoffice-extension-languagetool')
provides=('libreoffice-extension-dictionaries-fr')
-makedepends=('unzip')
-changelog=changelog
-source=("http://www.dicollecte.org/grammalecte/oxt/Grammalecte-fr-v${pkgver}.oxt"
- "LICENSE::https://www.mozilla.org/MPL/2.0/index.txt")
-noextract=(Grammalecte-fr-v${pkgver}.oxt)
-sha512sums=('3b57514ce54a459073aac16379e7fefd71f33ae613f7ed785a88e7c8d5d8b34b4e5213809d87f6dbcb204677e0949127e104363fd3c64f3c0f42bd9c7546c379'
- '200821d8e18270b50208764e1263206d3566b1fc2ed6cf3731d308f690fac0d7333a3e06189ee011dd849a3142fe60e9c5b4a7c599351639715ea3e6df148437')
+source=(
+ "http://www.dicollecte.org/grammalecte/oxt/Grammalecte-fr-v${pkgver}.oxt"
+)
+sha512sums=(
+ '5833d54d5a6644b257502930830d88425500b7eb12083888a35cf8cd68c6e85d4b87e960c0481d56bc1203c92262aa5842b70c92059400f424b33d2269e3f50e'
+)
package() {
- install -dm755 ${pkgdir}/usr/lib/libreoffice/share/extensions
- unzip -q ${srcdir}/Grammalecte-fr-v${pkgver}.oxt -d ${pkgdir}/usr/lib/libreoffice/share/extensions/grammalecte
-
- # fix world writable bit
- find "${pkgdir}/usr/lib/libreoffice/share/extensions/grammalecte/" \( -type d -exec chmod 755 {} \; \) -o \( -type f -exec chmod 644 {} \; \)
+ install -dm755 ${pkgdir}/usr/lib/libreoffice/share/extensions
+ unzip -q ${srcdir}/Grammalecte-fr-v${pkgver}.oxt -d ${pkgdir}/usr/lib/libreoffice/share/extensions/grammalecte
- install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ # fix world writable bit
+ find "${pkgdir}/usr/lib/libreoffice/share/extensions/grammalecte/" \( -type d -exec chmod 755 {} \; \) -o \( -type f -exec chmod 644 {} \; \)
}