summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSimon Wilper2021-02-24 18:57:28 +0100
committerSimon Wilper2021-02-24 18:57:28 +0100
commit4975636ffd42e9371a6e0e97e9afb3658a17a178 (patch)
tree02f1b1d573bf16f330f05525b33bcf52d505d07b /PKGBUILD
parentd2bbc1e31609e9d4229957390ab150bc28739b18 (diff)
downloadaur-4975636ffd42e9371a6e0e97e9afb3658a17a178.tar.gz
remove unknown build-version option
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 24 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ac44234ebc49..ff6d65fcbaf1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Simon Wilper <sxw@chronowerks.de>
pkgname=libreoffice-slim-git
pkgver=latest
-pkgrel=3
+pkgrel=4
pkgdesc="A slimmed down Git version of LibreOffice"
-arch=('x86_64' 'i386')
+arch=('x86_64')
url="https://www.libreoffice.org/community/developers/"
license=('GPL')
makedepends=('git' 'gperf' 'yasm' 'zip' 'unzip')
-_gitroot=https://anongit.freedesktop.org/git/libreoffice/core.git
+_gitroot=https://gerrit.libreoffice.org/core
_gitname=core
prepare() {
@@ -33,18 +33,33 @@ prepare() {
build_date=$(date +%Y%m%d)
./autogen.sh\
--disable-odk\
+ --disable-report-builder\
--with-package-format=archive\
--disable-cups\
+ --disable-lpsolve\
+ --disable-coinmp\
+ --disable-pdfimport\
+ --disable-crashdump\
+ --enable-optimized=yes\
+ --enable-lto\
+ --disable-gio\
--enable-release-build\
--enable-python=fully-internal\
+ --disable-neon\
+ --disable-mariadb-sdbc\
+ --disable-postgresql-sdbc\
+ --disable-firebird-sdbc\
+ --disable-dconf\
+ --disable-ldap\
+ --disable-opencl\
+ --disable-lotuswordpro\
--disable-gstreamer-1-0\
--with-galleries=no\
--with-java=no\
--without-fonts\
--without-help\
--with-vendor="sxw@chronowerks.de"\
- --with-extra-buildid="built by Chronowerks: ${build_hash}-${build_date}"\
- --with-build-version="${pkgver}-${pkgrel}"
+ --with-extra-buildid="built by Chronowerks: ${build_hash}-${build_date}"
}
build() {
@@ -53,6 +68,10 @@ build() {
cd workdir/installation/LibreOffice/archive/install/en-US
msg "Extracting LibreOffice Installation Tarball..."
tar xf *.tar.gz
+
+ msg "Patching boostraprc..."
+ cd LibreOffice*/program
+ sed -i -e 's@^UserInstallation.*@UserInstallation=$SYSUSERCONFIG/libreoffice@g' bootstraprc
}
package() {