summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDanilo Bargen2022-04-18 21:29:27 +0200
committerDanilo Bargen2022-04-18 21:29:27 +0200
commit367cc0a2fb2980a5af12c0a0bdb4a7428dcd40cf (patch)
tree9e4df742e6853b3c3f7e606f6a480891b23673df /PKGBUILD
parentd87f35f390e24ebb84292df098d75ebab349c75f (diff)
downloadaur-367cc0a2fb2980a5af12c0a0bdb4a7428dcd40cf.tar.gz
Fix CMake linking against muparser
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 13 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 950926979538..8842206c79e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgname=librepcb
pkgver=0.1.6
_pkgver=${pkgver/_/-}
-pkgrel=2
+pkgrel=3
pkgdesc="A free EDA software to develop printed circuit boards"
arch=('x86_64' 'i686')
url="https://librepcb.org/"
@@ -30,13 +30,25 @@ makedepends=(
source=(
"https://download.librepcb.org/releases/${_pkgver}/librepcb-${_pkgver}-source.zip"
"https://download.librepcb.org/releases/${_pkgver}/librepcb-${_pkgver}-source.zip.asc"
+ "cmake-muparser-fix.patch"
)
sha256sums=(
'8c7bf475ed59eb5b5e4b13073b96b9468ee01fb6980ef2b3471b1fbb39c46721'
'SKIP'
+ 'a59a830a77f7401c5dea02172eaee54ba40953b04404a393cf2314e4002410eb'
)
validpgpkeys=('D6F9AF572228C5BCD6B538407EF3061F5C8D5E25')
+prepare() {
+ cd "${srcdir}/librepcb-${_pkgver}/"
+
+ # Patch muparser include path
+ sed -i 's/muparser\/include\/muParser.h/muParser.h/' libs/librepcb/common/utils/mathparser.cpp
+
+ # Apply CMake fix (https://github.com/LibrePCB/LibrePCB/pull/970)
+ patch -p1 < "${srcdir}/cmake-muparser-fix.patch"
+}
+
build() {
cd "${srcdir}/librepcb-${_pkgver}/"
@@ -49,9 +61,6 @@ build() {
# Remove bundled hoedown, it is not needed on Qt >=5.14
rm -rf libs/hoedown/
- # Patch muparser include path
- sed -i 's/muparser\/include\/muParser.h/muParser.h/' libs/librepcb/common/utils/mathparser.cpp
-
# Build
mkdir -p build && cd build
cmake .. \