summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDanilo Bargen2020-10-05 09:35:33 +0200
committerDanilo Bargen2020-10-05 09:35:33 +0200
commit0baf763cd0e2287899c6979c9e11c25728ecfc6f (patch)
treee2d841c67bafacc5f1c12edf392589396aa7de5d /PKGBUILD
parentd5ae7b3fa99c19189f75c60d6e8ba1a3d252b949 (diff)
downloadaur-0baf763cd0e2287899c6979c9e11c25728ecfc6f.tar.gz
Version r2138.cf036e027
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 18 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e7b00259c6bf..98817f81d2bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,23 @@
# Maintainer: Danilo Bargen <aur at dbrgn dot ch>
+#
+# PGP key is on keyservers. To import:
+#
+# gpg --receive-keys 7EF3061F5C8D5E25
+#
+# See https://wiki.archlinux.org/index.php/Makepkg#Signature_checking
+# for more details # on package signing.
pkgname=librepcb-git
_fullname=LibrePCB
-pkgver=r2027.7276ce9f5
+pkgver=r2138.cf036e027
pkgrel=1
pkgdesc="A free EDA software to develop printed circuit boards (git master)"
arch=('x86_64' 'i686')
url="http://librepcb.org/"
license=('GPL')
-depends=('desktop-file-utils' 'hicolor-icon-theme' 'qt5-base' 'qt5-svg' 'quazip')
+depends=(
+ 'desktop-file-utils' 'hicolor-icon-theme' 'qt5-base' 'qt5-svg'
+ 'quazip' 'polyclipping'
+)
makedepends=('git' 'qt5-tools' 'fontobene-qt5')
provides=('librepcb')
conflicts=('librepcb')
@@ -23,7 +33,12 @@ build() {
# Prepare
cd "$srcdir/$_fullname-build"
mkdir build && cd build
- qmake -r ../librepcb.pro PREFIX="${pkgdir}/usr" CONFIG+=release UNBUNDLE+=quazip UNBUNDLE+=fontobene-qt5
+ qmake -r ../librepcb.pro \
+ PREFIX="${pkgdir}/usr" \
+ CONFIG+=release \
+ UNBUNDLE+=quazip \
+ UNBUNDLE+=polyclipping \
+ UNBUNDLE+=fontobene-qt5
# Compile
make