summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph Gysin2021-10-08 15:43:52 +0300
committerChristoph Gysin2021-10-08 15:44:02 +0300
commit082057bf96f9294fd24dd4a54fe84ba08782e802 (patch)
tree980b086c14920ed5c66d2afd5f37bad642819fb0 /PKGBUILD
parent8d5d006ccb9c7965fe1aff78e60f53cb9328815b (diff)
downloadaur-082057bf96f9294fd24dd4a54fe84ba08782e802.tar.gz
Add target for armv7h
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 942794201b07..0ba9d88c5d4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=librespot-git
_pkgname=librespot
pkgver=1383.095536f
-pkgrel=2
+pkgrel=3
epoch=1
pkgdesc="Open Source Spotify client library"
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
@@ -23,9 +23,15 @@ pkgver() {
prepare() {
cd "$_pkgname"
+
+ case "$CARCH" in
+ armv7h) target=armv7-unknown-linux-gnueabihf;;
+ *) target="$CARCH-unknown-linux-gnu";;
+ esac
+
cargo fetch \
--locked \
- --target "$CARCH-unknown-linux-gnu"
+ --target "$target"
}
build() {