summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexandre Bique2017-06-26 20:38:25 +0200
committerAlexandre Bique2017-06-26 20:38:25 +0200
commit5da5c5a05cb04c915655e427319032164a25a0ff (patch)
tree12c7a0891eedff713856ba8296f88ab7e9ceef61 /PKGBUILD
parent826c9eb586c616e5fcca662bbeb90dac77984b9a (diff)
downloadaur-5da5c5a05cb04c915655e427319032164a25a0ff.tar.gz
Update to 3.20, but added a lot of -Wno-error=... we should have none ideally...
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9385e6623798..cc3c62e5130d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# (Co-)Maintainer: Patrick Burroughs (Celti) <celti@celti.name>
pkgname=libreswan
-pkgver=3.19
+pkgver=3.20
pkgrel=1
pkgdesc="IPsec implementation with IKEv1 and IKEv2 keying protocols"
arch=('i686' 'x86_64')
@@ -15,14 +15,14 @@ conflicts=('freeswan' 'openswan' 'strongswan' 'ipsec-tools')
backup=('etc/ipsec.conf' 'etc/ipsec.secrets' 'etc/pam.d/pluto')
source=(https://download.libreswan.org/${pkgname}-${pkgver}.tar.gz
tmpfiles.conf)
-md5sums=('f2abcdcdccb2ec42f226a6dbb0528cad'
+md5sums=('72aecdf8314c0c47546d5ae2cf918191'
'77399a739ee99f8bc54837684d7c39d5')
build() {
cd $pkgname-$pkgver
# Disable new warning introduced with GCC 6 (-Wunused-const-variable=)
- export CFLAGS="$CFLAGS -Wno-error=sign-compare -Wno-error=unused-const-variable "
+ export CFLAGS="$CFLAGS -Wno-error=sign-compare -Wno-error=unused-const-variable -Wno-error=implicit-fallthrough -Wno-error=maybe-uninitialized -Wno-error=pointer-compare -Wno-error=format-truncation"
make \
USE_XAUTH=true USE_LIBCAP_NG=true USE_LEAK_DETECTIVE=false \