summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Severance2020-05-20 17:08:01 -0400
committerChris Severance2020-05-20 17:08:01 -0400
commit9f11c09f93160e79d2c5f9a94a659bea42bebac2 (patch)
tree91d9597f153e9872fdc2ed5f79b43e13f7bfeeba /PKGBUILD
parentaca2a1e493db73da6847f5da862da53c36872e85 (diff)
downloadaur-9f11c09f93160e79d2c5f9a94a659bea42bebac2.tar.gz
autu: Update to 3.32-2 issue 342
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 13 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9fc318550075..ffcdd82f1215 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
pkgname='libreswan'
#pkgname+='-git'
-pkgver=3.32
-pkgrel=1
+pkgver='3.32'
+pkgrel='2'
pkgdesc='IPsec implementation with IKEv1 and IKEv2 keying protocols'
arch=('i686' 'x86_64')
url='https://libreswan.org/'
@@ -73,7 +73,17 @@ build() {
fi
# Disable new warning introduced with GCC 6 (-Wunused-const-variable=)
- CFLAGS="$CFLAGS -Wno-error=sign-compare -Wno-error=unused-const-variable -Wno-error=implicit-fallthrough -Wno-error=maybe-uninitialized -Wno-error=pointer-compare -Wno-error=format-truncation" \
+ local _cf=(
+ -Wno-error=sign-compare
+ -Wno-error=unused-const-variable
+ -Wno-error=implicit-fallthrough
+ -Wno-error=maybe-uninitialized
+ -Wno-error=pointer-compare
+ -Wno-error=format-truncation
+ -DNSS_PKCS11_2_0_COMPAT=1 # nss 3.52 https://github.com/libreswan/libreswan/issues/342
+ )
+
+ CFLAGS="${CFLAGS} ${_cf[*]}" \
nice make -s "${_bargs[@]}" programs
}