summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaxime Gauduin2017-08-10 23:10:13 +0200
committerMaxime Gauduin2017-08-10 23:10:13 +0200
commitc684e958e5644b6cc2a1f81fe5918189be504e54 (patch)
tree6b51b2a09c55b52d7ee4e9adb9bdf8b899ef1bfe /PKGBUILD
parent104ce407130a51d2d12b1b366031697e85a7dfde (diff)
downloadaur-c684e958e5644b6cc2a1f81fe5918189be504e54.tar.gz
libretro-citra-git r5017.070430ed$-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 17 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a388977f3a3d..18cc5de53f8c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=libretro-citra-git
-pkgver=r4851.ae8cfe69
+pkgver=r5017.070430ed
pkgrel=1
pkgdesc='Nintendo 3DS core'
arch=('i686' 'x86_64')
@@ -9,18 +9,21 @@ url='https://github.com/libretro/citra'
license=('GPL2')
groups=('libretro-unstable')
depends=('gcc-libs' 'glibc')
-makedepends=('boost' 'cmake' 'git')
+makedepends=('cmake' 'git')
provides=('libretro-citra')
conflicts=('libretro-citra')
source=('libretro-citra::git+https://github.com/libretro/citra.git'
- 'git+https://github.com/philsquared/Catch#tag=v1.9.5'
+ 'citra-boost::git+https://github.com/citra-emu/ext-boost'
+ 'git+https://github.com/philsquared/Catch#tag=v1.9.6'
+ 'git+https://github.com/whoshuu/cpr#tag=1.3.0'
'git+https://github.com/weidai11/cryptopp'
'git+https://github.com/MerryMage/dynarmic'
- 'git+https://github.com/fmtlib/fmt#tag=3.0.2'
+ 'git+https://github.com/lsalzman/enet'
+ 'git+https://github.com/fmtlib/fmt#tag=4.0.0'
'git+https://github.com/svn2github/inih'
'git+https://github.com/neobrain/nihstro'
'citra-soundtouch::git+https://github.com/citra-emu/ext-soundtouch'
- 'git+https://github.com/herumi/xbyak#tag=v5.43'
+ 'git+https://github.com/herumi/xbyak#tag=v5.50'
'https://raw.githubusercontent.com/libretro/libretro-super/master/dist/info/citra_libretro.info')
sha256sums=('SKIP'
'SKIP'
@@ -31,6 +34,9 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
'a9404c4eb4fb8a4caca9efbbd764bd272381a7a6f4378a05e956e3efbe4ba79e')
pkgver() {
@@ -47,11 +53,16 @@ prepare() {
fi
mkdir build
- for submodule in externals/{catch,cryptopp/cryptopp,dynarmic,fmt,inih/inih,nihstro,soundtouch,xbyak}; do
+ for submodule in externals/{catch,cpr,cryptopp/cryptopp,dynarmic,enet,fmt,inih/inih,nihstro,xbyak}; do
git submodule init ${submodule}
git config submodule.${submodule}.url ../${submodule##*/}
git submodule update
done
+ for submodule in externals/{boost,soundtouch}; do
+ git submodule init ${submodule}
+ git config submodule.${submodule}.url ../citra-${submodule##*/}
+ git submodule update
+ done
}
build() {