summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaxime Gauduin2018-07-23 10:59:41 +0200
committerMaxime Gauduin2018-07-23 10:59:41 +0200
commitddc362a99846acdedd8b3aaa4b95c0519c6efd22 (patch)
tree8a5b23f6a21131669dbb916b8a0ec6e381be5799 /PKGBUILD
parentf1174faac26025ab5609d3e2dd6dbfbb2d795954 (diff)
downloadaur-ddc362a99846acdedd8b3aaa4b95c0519c6efd22.tar.gz
Push version updates
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 14 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 73eb4bbf6633..1e1f50f2b4c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=libretro-citra-git
-pkgver=r6073.7e78ed15
+pkgver=r6417.8dc34315
pkgrel=1
pkgdesc='Nintendo 3DS core'
arch=('x86_64')
@@ -16,12 +16,14 @@ source=('libretro-citra::git+https://github.com/libretro/citra.git'
'citra-boost::git+https://github.com/citra-emu/ext-boost.git'
'git+https://github.com/philsquared/Catch.git'
'git+https://github.com/weidai11/cryptopp.git'
+ 'git+https://github.com/kinetiknz/cubeb.git'
'git+https://github.com/MerryMage/dynarmic.git'
'git+https://github.com/lsalzman/enet.git'
'git+https://github.com/fmtlib/fmt.git'
'git+https://github.com/svn2github/inih.git'
'citra-libressl::git+https://github.com/citra-emu/ext-libressl-portable.git'
'git+https://github.com/neobrain/nihstro.git'
+ 'git+https://github.com/arsenm/sanitizers-cmake.git'
'citra-soundtouch::git+https://github.com/citra-emu/ext-soundtouch.git'
'git+https://github.com/herumi/xbyak.git')
sha256sums=('SKIP'
@@ -35,6 +37,8 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -51,7 +55,7 @@ prepare() {
fi
mkdir build
- for submodule in externals/{catch,cryptopp/cryptopp,dynarmic,enet,fmt,inih/inih,libressl,nihstro,xbyak}; do
+ for submodule in externals/{catch,cryptopp/cryptopp,cubeb,dynarmic,enet,fmt,inih/inih,libressl,nihstro,xbyak}; do
git submodule init ${submodule}
git config submodule.${submodule}.url ../${submodule##*/}
git submodule update
@@ -61,6 +65,14 @@ prepare() {
git config submodule.${submodule}.url ../citra-${submodule##*/}
git submodule update
done
+
+ cd externals/cubeb
+
+ for submodule in cmake/sanitizers-cmake; do
+ git submodule init ${submodule}
+ git config submodule.${submodule}.url ../../../${submodule##*/}
+ git submodule update
+ done
}
build() {