summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexandre Bouvier2022-10-18 19:16:37 +0200
committerAlexandre Bouvier2022-10-18 19:17:16 +0200
commit15715de5584f74c33eab9601eb33da3285ab00b5 (patch)
tree25573c8b4ff6f4f1a429393e4700a8e5faffb237 /PKGBUILD
parent6aae4277cc2ab81b3106ecac4279ae3f12952e37 (diff)
downloadaur-15715de5584f74c33eab9601eb33da3285ab00b5.tar.gz
update to 2.0.r63.gc5c941e9
* update depends * update patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2dc7099874a8..536714de7451 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,23 +3,24 @@
_reponame=flycast
_pkgname=libretro-$_reponame
pkgname=$_pkgname-git
-pkgver=2.0.r58.g387b9778
+pkgver=2.0.r63.gc5c941e9
pkgrel=1
pkgdesc="Sega Dreamcast core"
arch=('aarch64' 'armv7h' 'i486' 'i686' 'pentium4' 'x86_64')
url="https://github.com/flyinghead/flycast"
license=('GPL2')
groups=('libretro')
-depends=('libretro-core-info')
+depends=('glslang>=11.11' 'libretro-core-info')
makedepends=(
'cmake'
'git'
'glm'
- 'glslang>=11.11'
'libchdr'
'libgl'
'libzip'
'miniupnpc'
+ 'vulkan-headers'
+ 'vulkan-icd-loader'
'xbyak'
'xxhash'
'zlib'
@@ -36,7 +37,7 @@ b2sums=(
'SKIP'
'SKIP'
'SKIP'
- '667b64dab77b80d6091028d28b1c13e1e8f70d352d7d7f4fecb7f54a5db604f741a85d1e2e26ddef6be4e401a4d33209b7d919521452d81b169bf268759e75c2'
+ '86bf39dfb1152009819bcb92838b9eb2fd5572b47ed9d7cba2516a615dccc486608726c0e0a951dc77d07ddcd451bca8b20ff14a196244d210d68e23f0caceee'
)
pkgver() {
@@ -51,6 +52,7 @@ prepare() {
git submodule update
patch -Np1 < ../unbundle-libs.patch
rm -r core/deps/libretro-common/include/libchdr
+ sed -i 's/glm::glm/glm/' CMakeLists.txt
}
build() {