summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexandre Bouvier2022-10-06 23:35:41 +0200
committerAlexandre Bouvier2022-10-06 23:35:41 +0200
commit8fbd66ddf7a1384d79a8a3de0826035e324266fe (patch)
tree1b04becec4ad4145abb5da14cda4da6829648871 /PKGBUILD
parent1e9a6259a7d269ce65a70b5cc2adac9086e3b8b4 (diff)
downloadaur-8fbd66ddf7a1384d79a8a3de0826035e324266fe.tar.gz
update to 2.0.r53.gd22fa54f
* update patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 13 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 575e70475267..753d80366b3e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,21 @@
_reponame=flycast
_pkgname=libretro-$_reponame
pkgname=$_pkgname-git
-pkgver=2.0.r0.gaa97a6d6
+pkgver=2.0.r53.gd22fa54f
pkgrel=1
pkgdesc="Sega Dreamcast core"
arch=('aarch64' 'armv7h' 'i486' 'i686' 'pentium4' 'x86_64')
url="https://github.com/flyinghead/flycast"
license=('GPL2')
groups=('libretro')
-depends=('libgl' 'libretro-core-info')
+depends=('libretro-core-info')
makedepends=(
'cmake'
'git'
'glm'
+ 'glslang>=11.11'
'libchdr'
- 'libglvnd'
+ 'libgl'
'libzip'
'miniupnpc'
'xbyak'
@@ -27,11 +28,15 @@ provides=("$_pkgname")
conflicts=("$_pkgname")
source=(
"$_reponame::git+$url.git"
+ 'Vulkan-Headers::git+https://github.com/KhronosGroup/Vulkan-Headers.git'
+ 'VulkanMemoryAllocator::git+https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator.git'
'unbundle-libs.patch'
)
b2sums=(
'SKIP'
- 'e958858e145819df2156856b55b441b960716403c140cf79c6bbec5fbfae06303e27ea42f9fa4d58250046c9700ac04e5d26feb6a469ea9cd9cdda4c471ad896'
+ 'SKIP'
+ 'SKIP'
+ '2f2edc320cd63737a9fcdfa90265a8003a576e3797b43291b44c567eb189253bb0b48c7a5e7bc5b36d89c2889a064ecbd9c0deac6d8df526289de8cd0e2349a8'
)
pkgver() {
@@ -41,6 +46,9 @@ pkgver() {
prepare() {
cd $_reponame
+ git config submodule.core/deps/Vulkan-Headers.url ../Vulkan-Headers
+ git config submodule.core/deps/VulkanMemoryAllocator.url ../VulkanMemoryAllocator
+ git submodule update
patch -Np1 < ../unbundle-libs.patch
rm -r core/deps/libretro-common/include/libchdr
}
@@ -61,6 +69,7 @@ build() {
package() {
depends+=(
'libchdr.so'
+ 'libGL.so'
'libminiupnpc.so'
'libxxhash.so'
'libzip.so'