summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEugene Lebedev2020-03-29 02:40:14 +0300
committerEugene Lebedev2020-03-29 02:40:14 +0300
commit905235f7f5bc2a62ac4dbdae64b82b8bd0e38081 (patch)
tree97a419d9536e09829cc17cbcf1ed6ad5a0eaf731 /PKGBUILD
downloadaur-905235f7f5bc2a62ac4dbdae64b82b8bd0e38081.tar.gz
Add libretro-pcsx2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0850590c6bbd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Eugene Lebedev <satanych13+dev@gmail.com>
+
+pkgname=libretro-pcsx2-git
+pkgver=46.bc78bf9
+pkgrel=1
+pkgdesc="Launch Sony PlayStation 2 games through PCSX2, directly from RetroArch."
+arch=('x86_64')
+url="https://github.com/coldscientist/libretro-pcsx2-launcher"
+license=('MIT')
+conflicts=('libretro-pcsx2')
+provides=('libretro-pcsx2')
+depends=('pcsx2' 'libretro-core-info')
+makedepends=('git')
+groups=('libretro')
+
+source=("libretro-pcsx2::git+https://github.com/coldscientist/libretro-pcsx2-launcher.git")
+
+sha256sums=(SKIP)
+
+pkgver() {
+ cd libretro-pcsx2
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd libretro-pcsx2
+ make
+}
+
+package() {
+ install -Dm644 libretro-pcsx2/dolphin_launcher_libretro.so "${pkgdir}/usr/lib/libretro/pcsx2_launcher_libretro.so"
+ install -Dm644 libretro-pcsx2/dolphin_launcher_libretro.info "${pkgdir}/usr/share/libretro/info/pcsx2_launcher_libretro.info"
+}
+