summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTilman M. Jaeschke2023-03-27 09:59:05 +0200
committerTilman M. Jaeschke2023-03-27 09:59:05 +0200
commit08cdf6057b15ea134f4f08be76fe6444fe67f3cd (patch)
tree0dc0d97157ebb87dcad7ea77c5c80cfee4ccfe84 /PKGBUILD
parent7f64e96b802cead464d0721fd00648460f44e46e (diff)
downloadaur-08cdf6057b15ea134f4f08be76fe6444fe67f3cd.tar.gz
added patch to remove splash screen
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 12 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6e91c89e31ff..c10b5acd7903 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,23 @@
# Maintainer: Tilla <carlosfritz@posteo.net>
pkgname=(libretro-scummvm-git libretro-scummvm-datafiles-git libretro-scummvm-coreinfo-git)
-pkgver=140529.0c4e573ce53
+pkgver=140558.8247aad108c
pkgrel=1
pkgdesc="ScummVM core"
arch=(x86_64 aarch64)
-#url=https://github.com/scummvm/scummvm
url=https://github.com/libretro/scummvm
license=(GPL)
groups=(libretro)
#depends=(libretro-core-info)
makedepends=(git wget unzip)
conflicts=(libretro-scummvm)
-#source=(git+https://github.com/scummvm/scummvm.git)
-source=(git+https://github.com/libretro/scummvm.git)
-sha256sums=(SKIP)
+source=(git+https://github.com/libretro/scummvm.git remove_splash.patch)
+# Regarding splash screen removal, the source states:
+# // Please leave the splash screen in working order for your releases, even if they're commercial.
+# // This is a proper and good way to show your appreciation for our hard work over these years.
+# I disagree. Forced appreciation by showing an unnecessary screen and objectively worsen the core is not a good way at all.
+# I apologize to all devs that take offense. I am grateful and appreciate your work very much!
+sha512sums=(SKIP 0252280d86140476894a475738e42827dd6371ec50b46d58f432c43ea82330b750b9965ed42d62f5e46e327109546129b2a15410dbedce308e281e55c0abbb61)
# Where the datafiles will be installed
_sysdir=/home/player/.config/retroarch/system
@@ -22,6 +25,10 @@ _sysdir=/home/player/.config/retroarch/system
# Who will own them (user:group)
_sysown=player:player
+prepare() {
+ patch --forward --strip=1 --input="remove_splash.patch"
+}
+
pkgver() {
cd scummvm
echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)