summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOliver Jaksch2019-06-29 17:33:42 +0200
committerOliver Jaksch2019-06-29 17:33:42 +0200
commit28b10f897d9791865859b1c6f49eae0befadb49d (patch)
treec58e29ac036e8ab20a19311c44701fb5c49ae5b2 /PKGBUILD
downloadaur-28b10f897d9791865859b1c6f49eae0befadb49d.tar.gz
Rebrand to stella2014
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ebbd477ba910
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Oliver Jaksch <arch-aur@com-in.de>
+
+pkgname=libretro-stella2014-git
+pkgver=218.7cc0c44
+pkgrel=1
+pkgdesc="libretro implementation of Stella. (Atari 2600)"
+arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
+url="https://github.com/libretro/stella2014-libretro"
+license=('GPL2')
+groups=('libretro')
+depends=('zlib' 'glibc' 'libretro-core-info')
+makedepends=('git')
+conflicts=('libretro-stella-git')
+
+_libname=stella2014_libretro
+_gitname=stella2014-libretro
+source=("git+https://github.com/libretro/${_gitname}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_gitname}"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "${_gitname}"
+ make
+}
+
+package() {
+ install -Dm644 "${_gitname}/${_libname}.so" "${pkgdir}/usr/lib/libretro/${_libname}.so"
+}