summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPatrick Northon2023-12-26 03:18:24 -0500
committerPatrick Northon2023-12-26 03:18:24 -0500
commitae18cc0dba1fdf227f2d8c08ce83285947c289b3 (patch)
treebfedb39bfed1cd06743f1db878d441777f738c82 /PKGBUILD
parent0aa9da20a18c2898caf3a2a7aa2d70972bfdff93 (diff)
downloadaur-ae18cc0dba1fdf227f2d8c08ce83285947c289b3.tar.gz
Limit git rev-parse to 7 chars.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a1d01a51cbc9..5a8950633d3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _pkgname='libretro-swanstation'
pkgname=${_pkgname}-git
provides=(${_pkgname})
conflicts=(${_pkgname})
-pkgver=r5790.37674474
+pkgver=r5793.6a8c32b
pkgrel=1
pkgdesc='SwanStation is an open-source Libretro core implementation of DuckStation, a PSX emulator.'
url="https://github.com/libretro/swanstation"
@@ -21,7 +21,7 @@ pkgver() {
cd "${_srcdir}"
( set -o pipefail
git describe --abbrev=7 --long 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
)
}