summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorevs-ch2022-08-08 09:31:43 +0200
committerevs-ch2022-08-08 09:31:43 +0200
commitda2edcbc5c5df0772bf5a8cce0d0e0faa1cd3ee7 (patch)
tree8659b9aa7ab70290f9185b1e0bea22ea72cc93d9 /PKGBUILD
parent589608ce7c76635a566755dfe1d3fe045e8d5954 (diff)
downloadaur-da2edcbc5c5df0772bf5a8cce0d0e0faa1cd3ee7.tar.gz
v103.0.1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 15 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 157fd476a2f8..4ad2857e7566 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=librewolf
_pkgname=LibreWolf
-pkgver=103.0
-pkgrel=3
+pkgver=103.0.1
+pkgrel=1
pkgdesc="Community-maintained fork of Firefox, focused on privacy, security and freedom."
arch=(x86_64 aarch64)
license=(MPL GPL LGPL)
@@ -25,26 +25,28 @@ options=(!emptydirs !makeflags !strip !lto !debug)
_arch_git=https://raw.githubusercontent.com/archlinux/svntogit-packages/packages/firefox/trunk
_source_tag="${pkgver}-${pkgrel}"
# _source_commit='328f531b1b18ca0ba4f96483db89eeb129c41c4c' # not 'stable', but current source head
-# _settings_tag='6.7'
-_settings_commit='02212c3f44e7aa68b22c8febd9158580d7e4b74f'
+_settings_tag='6.7'
+# _settings_commit='02212c3f44e7aa68b22c8febd9158580d7e4b74f'
install='librewolf.install'
source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz{,.asc}
https://raw.githubusercontent.com/archlinux/svntogit-packages/1f6f9abcdcb2a03f259602b4671208b15cc6d4b9/trunk/zstandard-0.18.0.diff
$pkgname.desktop
"git+https://gitlab.com/${pkgname}-community/browser/source.git#tag=${_source_tag}"
- "git+https://gitlab.com/${pkgname}-community/settings.git#commit=${_settings_commit}"
+ "git+https://gitlab.com/${pkgname}-community/settings.git#tag=${_settings_tag}"
"default192x192.png"
"0018-bmo-1516081-Disable-watchdog-during-PGO-builds.patch"
+ "glibc236.patch"
)
# source_aarch64=()
-sha256sums=('acc41d050560db4c4177ea86e2d00e47d74229041fea4c02c0e9e87e64093773'
+sha256sums=('b2db4df5fae0801e6406686876e8115d9529fb93a01566f22548908ca6c2cf82'
'SKIP'
'a6857ad2f2e2091c6c4fdcde21a59fbeb0138914c0e126df64b50a5af5ff63be'
'21054a5f41f38a017f3e1050ccc433d8e59304864021bef6b99f0d0642ccbe93'
'SKIP'
'SKIP'
'959c94c68cab8d5a8cff185ddf4dca92e84c18dccc6dc7c8fe11c78549cdc2f1'
- '1d713370fe5a8788aa1723ca291ae2f96635b92bc3cb80aea85d21847c59ed6d')
+ '1d713370fe5a8788aa1723ca291ae2f96635b92bc3cb80aea85d21847c59ed6d'
+ '7c6277d6ac1d31b0733d2e04600e2304545cede8810afc691142a94c0a517bd1')
# sha256sums_aarch64=()
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
@@ -148,6 +150,12 @@ fi
# https://bugzilla.mozilla.org/show_bug.cgi?id=1530052
# patch -Np1 -i ${srcdir}/0001-Use-remoting-name-for-GDK-application-names.patch
+ # temporary workaround to build with glibc-2.36
+ # this is not beautiful
+ local _glibc_minor=$(pacman -Qi glibc | grep Version | sed -e 's/Version[[:space:]]*:[[:space:]][0-9]\.\(.*\)-[0-9]/\1/')
+ if [ "${_glibc_minor}" -gt 35 ]; then
+ patch -Np1 -i ../glibc236.patch
+ fi
# Unbreak build with python-zstandard 0.18.0
patch -Np1 -i ../zstandard-0.18.0.diff