summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavidLazarescu2023-08-23 21:13:33 +0200
committerDavidLazarescu2023-08-23 21:13:33 +0200
commit72db47492eae7cccc0e8ed6552ce036adbd559ba (patch)
treedd95d2a6b9bdcf2dceecdfde44830d7e790d06be /PKGBUILD
parent2ac499213d59903f3f60c59edd85cfa97b5f03e7 (diff)
downloadaur-72db47492eae7cccc0e8ed6552ce036adbd559ba.tar.gz
Added gcc to build dependencies and removed sudo
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fd20762e9034..085b27054350 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: David Lazarescu <prtnprvtmail@protonmail.com>
pkgname='librum'
pkgver=v.0.6.3.r14.g6774c2c
-pkgrel=4
+pkgrel=5
pkgdesc="A modern e-book reader and library manager"
arch=(x86_64)
url="https://librumreader.com"
license=('GPL3')
depends=('qt6-base' 'qt6-declarative' 'gcc-libs' 'glibc' 'krb5' 'brotli' 'zstd' 'zlib' 'libproxy' 'libglvnd' 'libx11' 'glib2' 'libxkbcommon' 'libpng' 'harfbuzz' 'md4c' 'freetype2' 'systemd-libs' 'double-conversion' 'libb2' 'pcre2' 'openssl' 'e2fsprogs' 'keyutils' 'expat' 'libxcb' 'dbus' 'graphite' 'bzip2' 'libcap' 'libgcrypt' 'xz' 'lz4' 'curl' 'duktape' 'libffi' 'libxau' 'libxdmcp' 'libgpg-error' 'libnghttp2' 'libidn2' 'libpsl' 'util-linux-libs' 'libunistring')
-makedepends=('git' 'make' 'cmake' 'unzip' 'python3')
+makedepends=('git' 'make' 'cmake' 'gcc' 'unzip' 'python3')
source=(Librum::"git+https://github.com/Librum-Reader/Librum.git")
md5sums=('SKIP')
@@ -30,5 +30,5 @@ build() {
package() {
cd "Librum"
- sudo cmake --install .
+ cmake --install .
}