summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas Iooss2020-03-03 21:01:39 +0100
committerNicolas Iooss2020-03-03 21:01:39 +0100
commit2289ce1dd6b65edea757e328ead1b344898834ca (patch)
tree5ff6af76ffea0d2aa52128032dfacff588539a43 /PKGBUILD
parentf717bef8131622ad8545f4bdffe7bafdc35e9808 (diff)
downloadaur-libselinux.tar.gz
Add pkgconf to makedepends
SELinux userspace libraries and tools require pkg-config in order to build with code using PCRE or DBUS. pkgconf should be installed on build systems, as it belongs to group base-devel, but some users did not install this package and report issues such as https://aur.archlinux.org/packages/libselinux/#comment-731794 Make everyone happy by adding pkgconf to the makedepends array. This should not modify the build (as pkgconf was already supposed to be installed), so there is no need to bump the pkgrel.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9acb10573de..280a3cdddc8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@ arch=('i686' 'x86_64' 'armv6h')
url='http://userspace.selinuxproject.org'
license=('custom')
groups=('selinux')
-makedepends=('python' 'ruby' 'xz' 'swig')
+makedepends=('pkgconf' 'python' 'ruby' 'xz' 'swig')
depends=('libsepol>=3.0' 'pcre')
optdepends=('python: python bindings'
'ruby: ruby bindings')