summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas Iooss2024-02-21 13:23:35 +0100
committerNicolas Iooss2024-02-21 13:23:35 +0100
commite1d1e3336c828980879d156756ccafb6107ebb14 (patch)
treedec45eb1df53c9c1435591f2db1c11abd82f3634 /PKGBUILD
parent7087e773a44b71d43fd9b8a4c694dab8da903b0b (diff)
downloadaur-e1d1e3336c828980879d156756ccafb6107ebb14.tar.gz
Add 'provides' with the shared library
This helps making package depends on a precise major version of a shared library.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4e293b6c02d8..9be66200f507 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgname=libselinux
pkgver=3.6
-pkgrel=2
+pkgrel=3
pkgdesc="SELinux library and simple utilities"
arch=('i686' 'x86_64' 'armv6h' 'aarch64')
url='https://github.com/SELinuxProject/selinux'
@@ -49,6 +49,10 @@ build() {
}
package() {
+ provides=(
+ libselinux.so
+ )
+
cd "${pkgname}-${pkgver}"
export DISABLE_RPM=y