summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas Iooss2020-07-19 11:32:29 +0200
committerNicolas Iooss2020-07-19 11:32:29 +0200
commitb182b8521f3cb582e86ba056bf6adc54165ca37b (patch)
tree4466bb26db41b68db2b18e92096be0c2419c6e54 /PKGBUILD
parentda6028ff529f9f1ebedf8bc3c05b79bd39d47e40 (diff)
downloadaur-b182b8521f3cb582e86ba056bf6adc54165ca37b.tar.gz
libsemanage 3.1-1 update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 12ab01ff9396..9c339ef54bd2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,28 +7,30 @@
# If you want to help keep it up to date, please open a Pull Request there.
pkgname=libsemanage
-pkgver=3.0
+pkgver=3.1
pkgrel=1
pkgdesc="SELinux binary policy manipulation library"
arch=('i686' 'x86_64')
-url='http://userspace.selinuxproject.org'
+url='https://github.com/SELinuxProject/selinux'
license=('LGPL2.1')
groups=('selinux')
makedepends=('flex' 'pkgconf' 'python' 'ruby' 'swig')
-depends=('libselinux>=3.0' 'audit')
+depends=('libselinux>=3.1' 'audit')
optdepends=('python: python bindings'
'ruby: ruby bindings')
options=(!emptydirs) # For /var/lib/selinux
install=libsemanage.install
conflicts=("selinux-usr-${pkgname}")
provides=("selinux-usr-${pkgname}=${pkgver}-${pkgrel}")
-source=("https://github.com/SELinuxProject/selinux/releases/download/20191204/${pkgname}-${pkgver}.tar.gz"
+source=("https://github.com/SELinuxProject/selinux/releases/download/20200710/${pkgname}-${pkgver}.tar.gz"
"semanage.conf")
-sha256sums=('a497b0720d54eac427f1f3f618eed417e50ed8f4e47ed0f7a1d391bd416e84cf'
+sha256sums=('22d6c75526e40d1781c30bcf29abf97171bdfe6780923f11c8e1c76a75a21ff8'
'5b0e6929428e095b561701ccdfa9c8b0c3d70dad3fc46e667eb46a85b246a4a0')
build() {
cd "${pkgname}-${pkgver}"
+
+ export CFLAGS="${CFLAGS} -fno-semantic-interposition"
make swigify
make all
make PYTHON=/usr/bin/python3 pywrap
@@ -41,7 +43,6 @@ package() {
make DESTDIR="${pkgdir}" PYTHON=/usr/bin/python3 LIBEXECDIR=/usr/lib SHLIBDIR=/usr/lib install-pywrap
make DESTDIR="${pkgdir}" RUBY=/usr/bin/ruby LIBEXECDIR=/usr/lib SHLIBDIR=/usr/lib install-rubywrap
/usr/bin/python3 -m compileall "${pkgdir}/$(/usr/bin/python3 -c 'from distutils.sysconfig import *; print(get_python_lib(plat_specific=1))')"
- /usr/bin/python3 -O -m compileall "${pkgdir}/$(/usr/bin/python3 -c 'from distutils.sysconfig import *; print(get_python_lib(plat_specific=1))')"
install -D -m0644 "${srcdir}/semanage.conf" "${pkgdir}/etc/selinux/semanage.conf"