summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas Iooss2024-02-21 13:23:35 +0100
committerNicolas Iooss2024-02-21 13:23:35 +0100
commitba9e9a3949d80140b74ad4505d8ad8be3dd86da2 (patch)
treedc63528278d468ce32fc999cdc7a0fd69ad00633 /PKGBUILD
parent05b4c2a226386701e461ef9b88e1dfbf32b72250 (diff)
downloadaur-ba9e9a3949d80140b74ad4505d8ad8be3dd86da2.tar.gz
Add 'provides' with the shared library
This helps making package depends on a precise major version of a shared library.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 206ed772e628..4501a8eaec9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
pkgname=libsemanage
pkgver=3.6
-pkgrel=1
+pkgrel=2
pkgdesc="SELinux binary policy manipulation library"
arch=('i686' 'x86_64' 'aarch64')
url='https://github.com/SELinuxProject/selinux'
@@ -43,6 +43,10 @@ build() {
}
package() {
+ provides=(
+ libsemanage.so
+ )
+
cd "${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" LIBEXECDIR=/usr/lib SHLIBDIR=/usr/lib install
make DESTDIR="${pkgdir}" PYTHON=/usr/bin/python3 LIBEXECDIR=/usr/lib SHLIBDIR=/usr/lib install-pywrap