summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas Iooss2020-05-18 22:42:07 +0200
committerNicolas Iooss2020-05-20 22:57:19 +0200
commit66e234eaa4be6d2c15d5452016b9c92c22168e0c (patch)
tree85a59b6a9fa7e1773b77407272488d74c7a372c5 /PKGBUILD
parent2ebd83d5201f5d0f12fc7ea39ebb08b3d6512716 (diff)
downloadaur-66e234eaa4be6d2c15d5452016b9c92c22168e0c.tar.gz
libsepol 3.0-2: build with clang
gcc 10 breaks libsepol linking: /usr/bin/ld: ../cil/src/cil_binary.lo:(.bss+0x3c0): multiple definition of `CIL_KEY_RANGE'; ../cil/src/cil.lo:(.bss+0x3c0): first defined here /usr/bin/ld: ../cil/src/cil_binary.lo:(.bss+0x3c8): multiple definition of `CIL_KEY_ALL'; ../cil/src/cil.lo:(.bss+0x3c8): first defined here ... As this issue will be fixed in the next release (which is expected in a few week) and as building with clang works, force using clang to build libsepol for now.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 44d55d2dbfd3..84b2cb7da40e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,13 +8,13 @@
pkgname=libsepol
pkgver=3.0
-pkgrel=1
+pkgrel=2
pkgdesc="SELinux binary policy manipulation library"
arch=('i686' 'x86_64' 'armv6h')
url='http://userspace.selinuxproject.org'
license=('LGPL2.1')
groups=('selinux')
-makedepends=('flex')
+makedepends=('clang' 'flex')
depends=('glibc')
options=(staticlibs)
conflicts=("selinux-usr-${pkgname}")
@@ -24,10 +24,10 @@ sha256sums=('5b7ae1881909f1048b06f7a0c364c5c8a86ec12e0ec76e740fe9595a6033eb79')
build() {
cd "${pkgname}-${pkgver}"
- make
+ make CC=clang
}
package() {
cd "${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" SHLIBDIR=/usr/lib install
+ make CC=clang DESTDIR="${pkgdir}" SHLIBDIR=/usr/lib install
}