summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas Iooss2016-03-22 10:47:40 +0100
committerNicolas Iooss2016-03-22 10:47:40 +0100
commit7fcdb58b8eca9d8cd0e8ace9faeef39827923392 (patch)
treec56b91625b9f85a1d245c0723430c6a665debc1a /PKGBUILD
parent3c5e34f73af31b192f8827e427543a2ce138cf4e (diff)
downloadaur-7fcdb58b8eca9d8cd0e8ace9faeef39827923392.tar.gz
libsepol 2.5-2 update
Add an upstream patch, "libsepol/cil: fix bug when resetting class permission values", https://github.com/SELinuxProject/selinux/commit/4df9f89cb1182f0dd324e271109efd7e2eda467b
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ad66c58c59b5..207b63e616da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=libsepol
pkgver=2.5
-pkgrel=1
+pkgrel=2
pkgdesc="SELinux binary policy manipulation library"
arch=('i686' 'x86_64' 'armv6h')
url='http://userspace.selinuxproject.org'
@@ -16,8 +16,17 @@ depends=('glibc')
options=(staticlibs)
conflicts=("selinux-usr-${pkgname}")
provides=("selinux-usr-${pkgname}=${pkgver}-${pkgrel}")
-source=("https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20160223/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('2bdeec56d0a08b082b93b40703b4b3329cc5562152f7254d8f6ef6b56afe850a')
+source=("https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20160223/${pkgname}-${pkgver}.tar.gz"
+ '0001-libsepol-cil-fix-bug-when-resetting-class-permission.patch')
+sha256sums=('2bdeec56d0a08b082b93b40703b4b3329cc5562152f7254d8f6ef6b56afe850a'
+ '5928a0feee0495d830b612175a6c57f7fc867306f04d022ba816bdee4606cfea')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+
+ # https://github.com/SELinuxProject/selinux/commit/4df9f89cb1182f0dd324e271109efd7e2eda467b
+ patch -Np2 -i '../0001-libsepol-cil-fix-bug-when-resetting-class-permission.patch'
+}
build() {
cd "${pkgname}-${pkgver}"