summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcgugas2019-06-17 07:33:52 -0500
committercgugas2019-06-17 07:35:34 -0500
commitad100b9a4a09e59f7ea6dce78b7c8850c5b77b45 (patch)
treedbabf9306ed34299a52e3e176463e434eb43df98 /PKGBUILD
parent362af5fbe9bbcf53ee9d47d6eac6878bbf5746f5 (diff)
downloadaur-ad100b9a4a09e59f7ea6dce78b7c8850c5b77b45.tar.gz
updated
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 28 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0f1da4b19502..263a68a559e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,32 +3,51 @@
_gitname=libserial
pkgname="${_gitname}-git"
-pkgver=r168.1201211
+pkgver=r516.ff5b6b0
pkgrel=1
pkgdesc="A library for accessing serial ports on POSIX systems (git version)"
arch=('x86_64')
url="https://github.com/crayzeewulf/${_gitname}/"
license=('GPL2')
-makedepends=('git' 'python2-sip' 'gtest')
+makedepends=(
+ 'git'
+ 'python-sip'
+ 'python-sphinx'
+ 'python-sphinx_rtd_theme'
+ 'gtest'
+ 'boost'
+)
conflicts=("${_gitname}")
provides=("${_gitname}")
+
source=("$pkgname"::"git+https://github.com/crayzeewulf/${_gitname}.git")
sha512sums=('SKIP')
pkgver() {
- cd "$pkgname"
+ cd "${pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "$pkgname"
+ cd "${pkgname}"
+
+
+ mkdir -p build
+ cd build
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib
- sed -i '1i#!/usr/bin/bash' compile.sh
- ./compile.sh
+ make
+
+ sphinx-build -b html "../docs/user_manual/" "docs/html/"
}
package() {
- cd "$pkgname"
- mkdir -p $pkgdir/usr/lib
- install -Dm555 build/lib/libserial.so "$pkgdir/usr/lib/"
+ cd "${pkgname}"
+ cd "build"
+ DESTDIR="${pkgdir}" make install
+
+ install -d "${pkgdir}/usr/share/docs/${gitname}"
+ cp -R "docs/html" "${pkgdir}/usr/share/docs/${gitname}"
}