diff options
author | Triss Healy | 2022-09-01 22:39:43 +1000 |
---|---|---|
committer | Triss Healy | 2022-09-01 22:39:43 +1000 |
commit | ecbea0c85911f9b2df4b01e522da77091ec2fa74 (patch) | |
tree | 7949012aa5079d6f17eea64af937d9e8102bfb8d /PKGBUILD | |
parent | d26ef83945310ff9d5575081db7016f4d9fe1e48 (diff) | |
download | aur-ecbea0c85911f9b2df4b01e522da77091ec2fa74.tar.gz |
Used XDG_CONFIG_* to prevent users break test.
GTK automatically reads ~/.config/gtk-4.0/settings.ini for users
customizations. If those customizations contain deprecated/removed
keys it creates a warning in GTK which causes the Tests to
automatically fail.
So we make a empty config dir and set $XDG_CONFIG_{DIR,HOME} to
prevent gtk reading those files.
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 11 |
1 files changed, 9 insertions, 2 deletions
@@ -3,7 +3,7 @@ _pkgname=libshumate pkgname=${_pkgname}-git pkgver=1.0.0.beta.r1.g32f8d1a -pkgrel=1 +pkgrel=2 pkgdesc="GTK4 widget to display maps (git version)" arch=(x86_64) url="https://wiki.gnome.org/Projects/libshumate" @@ -28,7 +28,14 @@ build() { } check() { - # Run tests with headless x11 server. + # Make a Empty $XDG_CONFIG_DIR to prevent issues to user + # customization breaking tests + mkdir -p $srcdir/test_config_dir + + # Run tests with headless x11 server. + env \ + XDG_CONFIG_DIR=$srcdir/test_config_dir \ + XDG_CONFIG_HOME=$srcdir/test_config_dir \ xvfb-run meson test -C build --print-errorlogs } |