summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGiorgi Kobakhidze2022-12-31 15:31:01 +0400
committerGiorgi Kobakhidze2022-12-31 15:31:01 +0400
commit0af89a802ba635ca1350b0b9480d6b5c52a8154a (patch)
tree90c50f0082731bea8ed811bcbe6997f148ed528b /PKGBUILD
parentaddb67803887687543da02d5d0afd652cc23d4e4 (diff)
downloadaur-0af89a802ba635ca1350b0b9480d6b5c52a8154a.tar.gz
Handle wasm file and conflict with the release version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c516c5769ea5..e7f8c7d196ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,14 @@
_pkgname=libsignal-protocol-javascript
pkgname="${_pkgname}-git"
pkgver=1.3.0.r5.g4fbea5a
-pkgrel=1
+pkgrel=3
license=(GPL3)
arch=(any)
url="https://github.com/signalapp/${_pkgname}"
+conflicts=("${_pkgname}")
makedepends=(emscripten npm grunt-cli)
source=("git+${url}")
-sha256sums=('SKIP')
+sha256sums=(SKIP)
pkgver() {
cd -- "${_pkgname}"
@@ -26,4 +27,5 @@ package() {
cd -- "${_pkgname}"
install -dm755 "$pkgdir"/usr/share/webapps/"${_pkgname}"
cp -R dist "$pkgdir"/usr/share/webapps/"${_pkgname}"/
+ cp build/curve25519_compiled.wasm "$pkgdir"/usr/share/webapps/"${_pkgname}"/dist/
}