summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVadim Yanitskiy2024-01-28 04:38:10 +0700
committerVadim Yanitskiy2024-01-28 04:38:10 +0700
commit541dbcde8b45d4ea27e2f02cc5fec7d38acf57fa (patch)
tree6ff2f2adcdc4d598fce691d319534647232854e5 /PKGBUILD
parent5d4ffb34d907eeb7a8264f24eec76c8d39da23d0 (diff)
downloadaur-libsmpp34-git.tar.gz
update $pkgver, $provides, $source, depend on libxml2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f390765c2c39..a0af809eccdc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
-# Maintainer: Josef Miegl <josef@miegl.cz>
+# Maintainer: Vadim Yanitskiy <fixeria@osmocom.org>
+# Contributor: Josef Miegl <josef@miegl.cz>
pkgname=libsmpp34-git
-pkgver=1.13.0.r3.g3cf5229
+pkgver=1.14.3.r2.g4b6d3f0
pkgrel=1
pkgdesc="Osmocom version of libsmpp34, an implementation of the SMPP Protocol v3.4"
url="http://osmocom.org/projects/libsmpp34"
arch=('i686' 'x86_64' 'aarch64' 'armv7h')
license=(GPL)
-depends=('libosmocore')
+depends=('libxml2')
makedepends=('git')
-provides=("${pkgname%-git}")
+provides=('libsmpp34.so=1-64')
conflicts=("${pkgname%-git}")
-source=("git+https://git.osmocom.org/${pkgname%-git}")
+source=("git+https://gitea.osmocom.org/cellular-infrastructure/${pkgname%-git}.git")
sha256sums=('SKIP')
pkgver() {
@@ -26,7 +27,9 @@ prepare() {
build() {
cd "${pkgname%-git}"
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var
make
}