summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJosef Miegl2019-02-13 20:24:59 +0100
committerJosef Miegl2019-02-13 20:24:59 +0100
commit5d4ffb34d907eeb7a8264f24eec76c8d39da23d0 (patch)
treeb26cf2ec9aa78bb8dccf0e62d341950476e78a5e /PKGBUILD
parent6c3fe545f6c2a0053757a03068dfbf0fb2b633a5 (diff)
downloadaur-5d4ffb34d907eeb7a8264f24eec76c8d39da23d0.tar.gz
update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 91d03ac511e7..f390765c2c39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Josef Miegl <josef@miegl.cz>
pkgname=libsmpp34-git
-pkgver=1.13.0.3.g3cf5229
+pkgver=1.13.0.r3.g3cf5229
pkgrel=1
pkgdesc="Osmocom version of libsmpp34, an implementation of the SMPP Protocol v3.4"
url="http://osmocom.org/projects/libsmpp34"
@@ -15,19 +15,23 @@ source=("git+https://git.osmocom.org/${pkgname%-git}")
sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${pkgname%-git}"
- echo $(git describe --always | sed 's/-/./g')
+ cd "${pkgname%-git}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${pkgname%-git}"
+ autoreconf -f -i
}
build() {
- cd "${srcdir}/${pkgname%-git}"
- autoreconf -i
- ./configure --prefix=/usr
+ cd "${pkgname%-git}"
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
make
}
package() {
- cd "${srcdir}/${pkgname%-git}"
+ cd "${pkgname%-git}"
make DESTDIR=${pkgdir} install
}