summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12017-08-19 16:00:08 +0800
committerChocobo12017-08-19 16:00:08 +0800
commit660a8b0158a80e0cf43ec02959994f4dfeee5cc3 (patch)
tree4a14dd83112bdfac10cd1a0dafef246212feeccb /PKGBUILD
parent213b8e97a2abb94db0e79cde1f5a2259df68bc0e (diff)
downloadaur-660a8b0158a80e0cf43ec02959994f4dfeee5cc3.tar.gz
upgpkg: libssh-git 0.3.0.r2774.gb9b89ef7-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 96c726186cfc..261c2dff3818 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=libssh-git
pkgver=0.3.0.r2774.gb9b89ef7
-pkgrel=1
+pkgrel=2
pkgdesc="Multiplatform C library implementing the SSHv2 and SSHv1 protocol on client and server side"
arch=('i686' 'x86_64')
url="https://www.libssh.org/"
@@ -11,6 +11,7 @@ depends=('glibc' 'openssl' 'zlib')
makedepends=('git' 'cmake' 'cmocka')
provides=('libssh')
conflicts=('libssh')
+options=('staticlibs')
source=("git://git.libssh.org/projects/libssh.git")
sha256sums=('SKIP')
@@ -18,7 +19,7 @@ sha256sums=('SKIP')
prepare() {
cd "libssh"
- mkdir -p "build"
+ mkdir -p "_build"
}
pkgver() {
@@ -28,20 +29,20 @@ pkgver() {
}
build() {
- cd "libssh/build"
+ cd "libssh/_build"
cmake -DCMAKE_INSTALL_PREFIX="/usr" -DCMAKE_BUILD_TYPE=Release -DWITH_TESTING=ON -DWITH_ZLIB=ON ../
make
}
check() {
- cd "libssh/build"
+ cd "libssh/_build"
make test
}
package() {
- cd "libssh/build"
+ cd "libssh/_build"
make DESTDIR="$pkgdir" install
}