summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKonstantin Shalygin2019-02-28 14:58:03 +0700
committerKonstantin Shalygin2019-02-28 14:58:03 +0700
commit7c59925d496c1cdc0533ea661edfd22607a7c518 (patch)
tree5719f3ecaae5eddcaca0bd102b362437e07d8abe /PKGBUILD
downloadaur-7c59925d496c1cdc0533ea661edfd22607a7c518.tar.gz
Added libstoragemgmt package.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8ed5092ed238
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Shalygin Konstantin <k0ste@k0ste.ru>
+# Contributor: Shalygin Konstantin <k0ste@k0ste.ru>
+
+pkgname='libstoragemgmt'
+pkgver='1.7.3'
+pkgrel='1'
+pkgdesc='A library for storage management'
+arch=('any')
+url="https://github.com/libstorage/${pkgname}"
+license=('GPL')
+depends=('libxml2' 'icu' 'sqlite' 'openssl')
+makedepends=('check' 'chrpath' 'valgrind' 'python-pywbem')
+optdepends=('arcconf: support for Microsemi (Adaptec) controllers')
+source=("${url}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('18e36665b645c1c41ad39fe8034e8f691104d72325881fb141e4bef97538ce80')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ autoreconf -fvi
+ PYTHON="/usr/bin/python" ./configure \
+ --prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/bin \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --libdir=/usr/lib \
+ --datarootdir=/usr/share \
+ --datadir=/usr/share \
+ --with-python3
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make
+}
+
+check() {
+ cd "${srcdir}/${pkgname}-${pkgver}/test"
+ ./runtests.sh
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}