summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWilliam Di Luigi2015-09-22 00:03:10 +0200
committerWilliam Di Luigi2015-09-22 00:03:10 +0200
commit0477a2f506c00fcbd7b1130258d1a754613d8cf4 (patch)
tree5af97aa90c5c2cb891b7abf77a1c89c84575cafa /PKGBUILD
downloadaur-0477a2f506c00fcbd7b1130258d1a754613d8cf4.tar.gz
First commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c7b303c1d056
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Gertjan Halkes <arch at ghalkes dot nl>
+pkgname=libt3config
+pkgver=0.2.10
+pkgrel=1
+pkgdesc="A library for reading and writing configuration files."
+arch=('x86_64' 'i686')
+url="http://os.ghalkes.nl/t3/$pkgname.html"
+license=('GPL3')
+groups=()
+depends=('gettext')
+makedepends=()
+optdepends=()
+conflicts=()
+replaces=()
+backup=()
+options=('!libtool')
+install=''
+changelog=
+source=("http://os.ghalkes.nl/dist/$pkgname-$pkgver.tar.bz2")
+noextract=()
+md5sums=('33468b8cb3e041c93b02f4b787f5265d')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr CFLAGS="-O2 -D_POSIX_C_SOURCE=200809L"
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}/usr/share/doc/$pkgname/API"
+}