summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWilliam Di Luigi2015-09-22 00:05:27 +0200
committerWilliam Di Luigi2015-09-22 00:05:27 +0200
commit548549e36b234f7047f3ed465da9674104f9804c (patch)
tree01ed9f257367bdd337f9950ab09a1eb6c274d5d1 /PKGBUILD
downloadaur-548549e36b234f7047f3ed465da9674104f9804c.tar.gz
First commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93e41cb03e83
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Gertjan Halkes <arch at ghalkes dot nl>
+pkgname=libt3highlight
+pkgver=0.3.5
+pkgrel=1
+pkgdesc="A syntax highlighting library."
+arch=('x86_64' 'i686')
+url="http://os.ghalkes.nl/t3/$pkgname.html"
+license=('GPL3')
+groups=()
+depends=('libt3config>=0.2.5')
+makedepends=()
+optdepends=()
+conflicts=()
+replaces=()
+backup=()
+options=('!libtool')
+install=''
+changelog=
+source=("http://os.ghalkes.nl/dist/$pkgname-$pkgver.tar.bz2")
+noextract=()
+md5sums=('f94e06aeae9f66807a7d7aeccd593610')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr CFLAGS="-O2 -D_POSIX_C_SOURCE=200809L"
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}/usr/share/doc/$pkgname/API"
+}