summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVincent Grande2021-01-08 21:18:07 -0500
committerVincent Grande2021-01-08 21:18:07 -0500
commit3ec8fa0f7482dda9e64b81630b6fc7d4b10b8f05 (patch)
tree0bade79958889fd6d63bf7167ceec7ee2b7a6380 /PKGBUILD
downloadaur-3ec8fa0f7482dda9e64b81630b6fc7d4b10b8f05.tar.gz
initial upload
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3e1cc9a8d137
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: AndyRTR <andyrtr@archlinux.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+# Contributor: judd <jvinet@zeroflux.org>
+
+pkgname=libtasn1-git
+pkgver=4.16.0
+pkgrel=1
+pkgdesc="The ASN.1 library used in GNUTLS"
+arch=('x86_64')
+license=('GPL3' 'LGPL')
+url="https://www.gnu.org/software/libtasn1/"
+depends=('glibc')
+source=(git+https://gitlab.com/gnutls/libtasn1.git)
+provides=(libtasn1)
+conflicts=(libtasn1)
+sha256sums=('SKIP')
+#validpgpkeys=('1F42418905D8206AA754CCDC29EE58B996865171') #Nikos Mavrogiannopoulos <nmav@gnutls.org>
+
+pkgver() {
+ cd libtasn1
+ git describe --tags | sed 's/-/+/g'
+}
+
+build() {
+ cd libtasn1
+ ./bootstrap
+ ./configure --prefix=/usr --disable-doc
+ CODE_COVERAGE_LDFLAGS=${LDFLAGS} make
+}
+
+#check() {
+# cd libtasn1
+# make check
+#}
+
+package() {
+ cd libtasn1
+ make DESTDIR="${pkgdir}" install
+# make -C doc/reference DESTDIR="${pkgdir}" install-data-local
+}