summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFélix Serrano Blanco2019-09-29 18:02:51 +0200
committerFélix Serrano Blanco2019-09-29 18:02:51 +0200
commit0ee79aa2a10109eb70e6a2239ee77f350c908d54 (patch)
tree3ff5064573e0a2444ae3e14ba9987e012f4ce319 /PKGBUILD
downloadaur-0ee79aa2a10109eb70e6a2239ee77f350c908d54.tar.gz
Initial import: 1.5.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aeebd36509fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Felix Serrano Blanco <felixseblanc@gmail.com>
+
+_pkgname=libtd
+pkgname=${_pkgname}
+pkgver=1.5.0
+pkgrel=1
+pkgdesc='Cross-platform library for building Telegram clients'
+arch=('x86_64')
+url='https://core.telegram.org/tdlib'
+license=('Boost')
+depends=(
+ 'openssl'
+ 'zlib'
+)
+makedepends=(
+ 'git'
+ 'gcc>=4.9.2'
+ 'make'
+ 'cmake>=3.0.2'
+ 'gperf'
+ 'php'
+)
+provides=('libtd')
+conflicts=('telegram-tdlib')
+source=("$_pkgname::git+https://github.com/tdlib/td.git#tag=v$pkgver")
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/$_pkgname"
+ rm -rf build
+ mkdir build
+ cd build
+ CXXFLAGS=""
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX:PATH="$pkgdir/usr" ..
+ cmake --build .
+}
+
+package() {
+ cd "$srcdir/$_pkgname/build"
+ mkdir -p "$pkgdir/usr"
+ cmake --build . --target install
+} \ No newline at end of file