summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgustawho2021-12-19 12:58:16 -0700
committergustawho2021-12-19 12:58:16 -0700
commitfaceace865a3f8cb64fe8bd052836029845524a3 (patch)
treee49511449b8ff92ee7adbfbac33aace11dc971bd /PKGBUILD
parent5a49123bb7059c3d633ba53f054c37c6cf95743e (diff)
downloadaur-faceace865a3f8cb64fe8bd052836029845524a3.tar.gz
Fixed CXXFLAGS
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1f1fb3cf0c2a..549979129b8a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Previous Contributor: Felix Serrano Blanco <felixseblanc@gmail.com>
pkgname=libtd-git
-pkgver=1.7.0.r760.g445183e5
+pkgver=1.7.0.r1935.g4eaae330
pkgrel=1
pkgdesc='TDLib (Telegram Database library) is a cross-platform library for building Telegram clients (Git)'
arch=('x86_64' 'arm' 'armv7h' 'armv6h' 'aarch64')
@@ -22,10 +22,11 @@ pkgver() {
}
build() {
+ CXXFLAGS+=' -fpermissive'
cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=RelWithDebInfo -B build -S "${pkgname%-git}"
cmake --build build --config RelWithDebInfo
}
package() {
DESTDIR="${pkgdir}" cmake --install build --config RelWithDebInfo
-} \ No newline at end of file
+}