summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFlorian Walch2015-08-30 12:43:33 +0200
committerFlorian Walch2015-08-30 12:48:46 +0200
commit4bd8c5a492955ac6af68290669644de1b6bf7247 (patch)
tree2d87458a3901ebfd0ce58d0ddf341b952a4d118c /PKGBUILD
parent2bbd8c2a3ba5460f917d23ea5c256bd265ec7169 (diff)
downloadaur-4bd8c5a492955ac6af68290669644de1b6bf7247.tar.gz
Add 'staticlibs' option to PKGBUILD.
As this is a VCS package, the library's API might change at any time. Projects using this library thus might want to link it statically.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8188944938cb..df6dc630e748 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=libtermkey-bzr
pkgver=0.17.r12
-pkgrel=2
+pkgrel=3
pkgdesc='Library for easy processing of keyboard entry from terminal-based programs.'
arch=('i686' 'x86_64')
url='http://www.leonerd.org.uk/code/libtermkey'
@@ -13,10 +13,11 @@ conflicts=('libtermkey')
provides=("libtermkey=${pkgver}")
source=("${pkgname}::bzr+http://bazaar.leonerd.org.uk/c/libtermkey/")
sha256sums=('SKIP')
+options=('staticlibs')
pkgver() {
cd "${pkgname}"
- bzr tags | sort -n -k3 | awk -v REV="$(bzr revno)" 'END{ printf("%s.r%s\n", $2, REV-$3) }'
+ bzr tags | sort -n -k3 | awk -v REV="$(bzr revno)" 'END { printf("%s.r%s\n", $2, REV-$3) }'
}
build() {