summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIlya Fedin2020-01-06 13:14:37 +0400
committerIlya Fedin2020-01-06 13:14:37 +0400
commit69e7628c78faf888f1b8bcc8ae5fa5729283ee09 (patch)
treee4b3f22dae083ba4de257784eed44801170745f5 /PKGBUILD
parentd249f49989e33b0e49af99f5ffec6d7088cdd346 (diff)
downloadaur-69e7628c78faf888f1b8bcc8ae5fa5729283ee09.tar.gz
Update to 88b47b6 and add a pkg-config path
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 14 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e32a6e190711..21a3d0820563 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=libtgvoip
pkgver=2.4.4
-pkgrel=2
+pkgrel=3
pkgdesc="VoIP library for Telegram clients"
arch=(x86_64)
url="https://github.com/telegramdesktop/libtgvoip"
@@ -12,13 +12,23 @@ optdepends=(
'alsa-lib: for alsa support'
'libpulse: for pulseaudio support'
)
-_commit="303dcacc2ad0428fd165c71455056d3f8f884d6f"
-source=("https://github.com/telegramdesktop/libtgvoip/archive/${_commit}.zip")
+_commit="88b47b6f808f2573d4eaf37e1463ecd59c43deda"
+source=(
+ "https://github.com/telegramdesktop/libtgvoip/archive/${_commit}.zip"
+ "libtgvoip-use-pkgconfig.patch"
+)
+
+sha512sums=('38dc34d6ce197d7dfaf06b5bef305fb7099586c14aa2a0142f0cd0f6bca2fdd96e23be22f00ae195a7e89e08c2a6a6f36c1a618e8e4eeb50a507f266c1b4ae21'
+ '70b97446c5bb89cf6b6d2ebfb43ad88172d7e41481b4cd2ad6fd800b403bb432b1e68d022141e288c556046e5bd8c802788c6d69ac242cbc90d900d76ac8ae74')
-sha512sums=('f369a99fc8cc39a6b62c81fa8513bfe187d3c91a747cd12fee0dfddec6ef26eac6c24b124e4212304796e679286cf5eaa303a731620a08e230a5f0ded71857b9')
+prepare() {
+ cd "$srcdir/$pkgname-${_commit}"
+ patch -Np1 -i "$srcdir/libtgvoip-use-pkgconfig.patch"
+}
build() {
cd "$srcdir/$pkgname-${_commit}"
+ autoreconf -i
./configure --prefix=/usr
make
}