summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12017-08-12 17:14:48 +0800
committerChocobo12017-08-12 17:25:18 +0800
commit375e0609d686f47d6c90b2cc725fb81c4d8dfa05 (patch)
treeb7221bbaddea7fbcd1aa4ccc81a55fd8d22cd50f /PKGBUILD
downloadaur-375e0609d686f47d6c90b2cc725fb81c4d8dfa05.tar.gz
newpkg: libtheora-git 1.2.0alpha1.r129.gfa5707d-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e6b3c3759dd2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=libtheora-git
+pkgver=1.2.0alpha1.r129.gfa5707d
+pkgrel=1
+pkgdesc="An open video codec developed by the Xiph.org"
+arch=('i686' 'x86_64')
+url="https://www.theora.org/"
+license=('BSD')
+depends=('glibc' 'libogg')
+makedepends=('git' 'libvorbis')
+provides=('libtheora')
+conflicts=('libtheora')
+source=("git+https://git.xiph.org/theora.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "theora"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "theora"
+
+ ./autogen.sh
+ ./configure --prefix="/usr" --disable-examples
+ make
+}
+
+check() {
+ cd "theora"
+
+ make check
+}
+
+package() {
+ cd "theora"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "COPYING" "$pkgdir/usr/share/licenses/libtheora/COPYING"
+}