summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoraksr2015-08-28 17:25:50 +0200
committeraksr2015-08-28 17:25:50 +0200
commit30cc773e8cf5a62268895af76df52bbec4f1a422 (patch)
tree8bcc98bd7138de433604b3a6af0ab70ca964294b /PKGBUILD
downloadaur-30cc773e8cf5a62268895af76df52bbec4f1a422.tar.gz
Start.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd159fba9e69
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Contributor: Lucky <archlinux@builds.lucky.li>
+## Based on libtorrent [community]
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=libtorrent-git
+pkgver=0.13.4.r103.g7b1b126
+pkgrel=1
+pkgdesc="A BitTorrent library written in C++."
+url="http://libtorrent.rakshasa.no"
+license=("GPL")
+arch=("i686" "x86_64")
+depends=("libsigc++" "openssl")
+makedepends=("cppunit" "git")
+conflicts=('libtorrent')
+provides=('libtorrent')
+options=("!libtool")
+source=("$pkgname::git+https://github.com/rakshasa/libtorrent.git")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --long | sed -r "s/([^-]*-g)/r\1/;s/-/./g"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ ./autogen.sh
+ export CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"
+ ./configure --prefix=/usr --disable-debug
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir" install
+}
+