summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoraksr2018-06-25 09:25:26 +0200
committeraksr2018-06-25 09:26:13 +0200
commitcc062762815f0ed100804a929619312a81ea7adb (patch)
tree59a32a276257cc329201656f0fdeb0721054a58a /PKGBUILD
parent7a391f5e2c302b9753478c6bcdd54054f23e60f0 (diff)
downloadaur-cc062762815f0ed100804a929619312a81ea7adb.tar.gz
Amend dependency array and delete patch-file.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 6 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e6650567b942..1cdc68c22021 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,31 +2,28 @@
## Based on libtorrent [community]
# Maintainer: aksr <aksr at t-com dot me>
pkgname=libtorrent-git
-pkgver=0.13.4.r176.gc167c5a9
+pkgver=0.13.7.r1.g7b29b6bd
pkgrel=1
pkgdesc="A BitTorrent library written in C++."
url="https://github.com/rakshasa/libtorrent/"
license=("GPL")
arch=("i686" "x86_64")
-depends=("libsigc++" "openssl")
-makedepends=("cppunit" "git")
+depends=("libsigc++" "openssl" "cppunit")
+makedepends=("git")
conflicts=('libtorrent')
provides=('libtorrent')
options=("!libtool")
-source=("$pkgname::git+https://github.com/rakshasa/libtorrent.git"
- libtorrent-openssl-1.1.patch::"https://github.com/rakshasa/libtorrent/commit/4607bbf7.patch")
-md5sums=('SKIP'
- 'f041643ba1c308e915fba0b4c9a9e685')
+source=("$pkgname::git+https://github.com/rakshasa/libtorrent.git")
+md5sums=('SKIP')
pkgver() {
cd "$srcdir/$pkgname"
- git describe --long | sed -r "s/([^-]*-g)/r\1/;s/-/./g"
+ git describe --long | sed -r "s/([^-]*-g)/r\1/;s/-/./g;s/^v//"
}
prepare() {
cd "$srcdir/$pkgname"
sed '/AM_PATH_CPPUNIT/d' -i configure.ac
- patch -p1 -i ../libtorrent-openssl-1.1.patch
}
build() {