summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAllen Zhong2022-03-23 18:52:48 +0800
committerAllen Zhong2022-03-23 18:52:48 +0800
commit862ae1c8c2c8de7dc5b0984387ded732156f9206 (patch)
tree0773d4aca2a965a3392c1bd343e4547ebaea15ac /PKGBUILD
parent4f2d95e9790dc316d16cfc477bc441984af278fd (diff)
downloadaur-862ae1c8c2c8de7dc5b0984387ded732156f9206.tar.gz
update source to latest dev branch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e060eeaa814c..b4a1fff38afa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
_pkgname=libtorrent
pkgname=libtorrent-ipv6
pkgver=0.13.8
-pkgrel=1
+pkgrel=3
pkgdesc='BitTorrent library with a focus on high performance and good code, with ipv6 support'
url='http://rakshasa.github.io/rtorrent/'
arch=('x86_64')
@@ -18,19 +18,22 @@ depends=('openssl' 'zlib')
makedepends=('git')
conflicts=("${_pkgname}")
provides=("${_pkgname}")
-source=("$_pkgname::git+https://github.com/rakshasa/libtorrent.git#commit=bd3e232a2fdb91a2eb93994bb18e5e0e3d2f6235")
+source=("$_pkgname::git+https://github.com/rakshasa/libtorrent.git#commit=ac8d6d1be5341e8dfa4ac33fef0bf8940a00c8f3")
sha256sums=('SKIP')
prepare() {
cd "${srcdir}/${_pkgname}"
sed '/AM_PATH_CPPUNIT/d' -i configure.ac
+ aclocal -I ./scripts -I .
+ autoheader
+ libtoolize --automake --copy --force
+ automake --add-missing --copy --gnu
+ autoconf
}
build() {
cd "${srcdir}/${_pkgname}"
- ./autogen.sh
-
- export CXXFLAGS="${CXXFLAGS} -std=c++11 -fno-strict-aliasing"
+ export CXXFLAGS="${CXXFLAGS} -std=c++14 -fno-strict-aliasing"
./configure \
--prefix=/usr \
--disable-debug