summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAllen Zhong2024-03-26 00:18:40 +0900
committerAllen Zhong2024-03-26 00:18:40 +0900
commita1108a1c0a24447e16deb2a1e387bce066cf828e (patch)
tree84206e080053e4d3a9b8ef365bbbbde1547d566b /PKGBUILD
parent9efc5dcc5691b80c90349b9aa6ef99a3a7be5cbf (diff)
downloadaur-a1108a1c0a24447e16deb2a1e387bce066cf828e.tar.gz
apply patch from track-ipv6 branch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1614b9ea1f87..0ed0bc943af9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
# $Id$
-# Maintainer: Allen Zhong <moeallenz@gmail.com>
+# Maintainer: Allen Zhong <pdev@zhoal.pw>
# Contributor: Gaetan Bisson <bisson@archlinux.org>
# Contributor: Jaroslav Lichtblau <svetlemodry@archlinux.org>
# Contributor: Daenyth <Daenyth+Arch [at] gmail [dot] com>
@@ -11,18 +11,21 @@ pkgname=libtorrent-ipv6
pkgver=0.13.8
pkgrel=4
pkgdesc='BitTorrent library with a focus on high performance and good code, with ipv6 support'
-url='http://rakshasa.github.io/rtorrent/'
+url='https://github.com/rakshasa/libtorrent'
arch=('x86_64')
license=('GPL')
depends=('openssl' 'zlib')
makedepends=('git')
conflicts=("${_pkgname}")
provides=("${_pkgname}")
-source=("$_pkgname::git+https://github.com/rakshasa/libtorrent.git#commit=ac8d6d1be5341e8dfa4ac33fef0bf8940a00c8f3")
-sha256sums=('SKIP')
+source=("$_pkgname::git+https://github.com/rakshasa/libtorrent.git#commit=91f8cf4b0358d9b4480079ca7798fa7d9aec76b5"
+ tracker-ipv6.patch)
+sha256sums=('a5dcc71582ab775981cb9133bf07392926f482843972c8874743f92f7f305851'
+ 'c0b08f7dec58136ed705c46a07fcd10b1c2b828462486b7e1df25c499b910a15')
prepare() {
cd "${srcdir}/${_pkgname}"
+ patch -Np1 -i ../tracker-ipv6.patch
sed '/AM_PATH_CPPUNIT/d' -i configure.ac
aclocal -I ./scripts -I .
autoheader