summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAllen Zhong2018-02-08 10:56:47 +0800
committerAllen Zhong2018-02-08 10:56:47 +0800
commitc1081d9648e538b8960a243301b5eb629ab205f7 (patch)
tree1c7638475bf815f20b86889802637f9fca994ae5 /PKGBUILD
parentf953774df9c1fb9eee2de80faf4528a8eca19bc5 (diff)
downloadaur-c1081d9648e538b8960a243301b5eb629ab205f7.tar.gz
upgpkg: libtorrent-ipv6 0.13.6-3
* Switch to git branch feature-bind
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 6 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d6ee0a22de83..cf85dd16a46d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,38 +9,28 @@
_pkgname=libtorrent
pkgname=libtorrent-ipv6
pkgver=0.13.6
-pkgrel=3
+pkgrel=4
pkgdesc='BitTorrent library with a focus on high performance and good code, with ipv6 support'
url='http://rakshasa.github.io/rtorrent/'
-arch=('i686' 'x86_64')
+arch=('x86_64')
license=('GPL')
depends=('openssl')
+makedepends=('git')
conflicts=("${_pkgname}")
provides=("${_pkgname}")
-source=("$_pkgname-$pkgver.tar.gz::https://github.com/rakshasa/${_pkgname}/archive/${pkgver}.tar.gz"
- "${_pkgname}-ipv6.patch"
- libtorrent-openssl-1.1.patch::"https://github.com/rakshasa/libtorrent/commit/4607bbf7.patch"
- fixing-memleak-with-getifaddrs.patch::"https://github.com/inste/libtorrent/commit/bdf08623.patch")
-sha256sums=('bf963ac6e73e194a2cd87ebdf809988b5b3d6244bb7cd43d7d0c4852fc501524'
- 'e359fe6ab6671c4db25c1cda92e0604d12943dc693abbdccd0a9d8a356581526'
- '82f639c1e7cf3299c2a44a705e69286abd33a75c70d2da0594d41d5a08cd8c1a'
- '513b14dda844082f90b486384d853ddaa316652ba5cb5f8e31c819878d0c59ba')
+source=("$_pkgname-$pkgver::git+https://github.com/rakshasa/libtorrent.git#commit=9eb9ba21720e544af3550f59900318a9b4d4a532")
+sha256sums=('SKIP')
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- patch -uNp1 -i "${srcdir}/${_pkgname}-ipv6.patch"
- # https://github.com/inste/libtorrent/commit/bdf086234cc6ea07364c6ef20e08c5fc504b70db
- patch -uNp1 -i "${srcdir}/fixing-memleak-with-getifaddrs.patch"
sed '/AM_PATH_CPPUNIT/d' -i configure.ac
- # fix build against openssl 1.1
- patch -uNp1 -i "${srcdir}"/libtorrent-openssl-1.1.patch
}
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
./autogen.sh
- export CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"
+ export CXXFLAGS="${CXXFLAGS} -std=c++11 -fno-strict-aliasing"
./configure \
--prefix=/usr \
--disable-debug