summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAllen Zhong2017-04-30 02:53:40 +0800
committerAllen Zhong2017-04-30 02:53:40 +0800
commitf953774df9c1fb9eee2de80faf4528a8eca19bc5 (patch)
treee72d6452d89cccadd13059056a551a1e96ee4bfb /PKGBUILD
parentc95940d4656ad961ca0a47ed062bc7fd722c6bdb (diff)
downloadaur-f953774df9c1fb9eee2de80faf4528a8eca19bc5.tar.gz
upgpkg: libtorrent-ipv6 0.13.6-3
+ Add memory missing patch * Fix build with OpenSSL 1.1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fb13435202af..d6ee0a22de83 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
_pkgname=libtorrent
pkgname=libtorrent-ipv6
pkgver=0.13.6
-pkgrel=2
+pkgrel=3
pkgdesc='BitTorrent library with a focus on high performance and good code, with ipv6 support'
url='http://rakshasa.github.io/rtorrent/'
arch=('i686' 'x86_64')
@@ -19,10 +19,12 @@ conflicts=("${_pkgname}")
provides=("${_pkgname}")
source=("$_pkgname-$pkgver.tar.gz::https://github.com/rakshasa/${_pkgname}/archive/${pkgver}.tar.gz"
"${_pkgname}-ipv6.patch"
- "fixing-memleak-with-getifaddrs.patch")
-sha1sums=('9ca6ca9698f81c758fe934b52374f23588a7cc78'
- '3a0925101ada86a4b0cff03ce1c704fd8dfd80a3'
- '933a94ca664fd98b05d4a326e683dbc0a7e250bd')
+ libtorrent-openssl-1.1.patch::"https://github.com/rakshasa/libtorrent/commit/4607bbf7.patch"
+ fixing-memleak-with-getifaddrs.patch::"https://github.com/inste/libtorrent/commit/bdf08623.patch")
+sha256sums=('bf963ac6e73e194a2cd87ebdf809988b5b3d6244bb7cd43d7d0c4852fc501524'
+ 'e359fe6ab6671c4db25c1cda92e0604d12943dc693abbdccd0a9d8a356581526'
+ '82f639c1e7cf3299c2a44a705e69286abd33a75c70d2da0594d41d5a08cd8c1a'
+ '513b14dda844082f90b486384d853ddaa316652ba5cb5f8e31c819878d0c59ba')
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
@@ -30,17 +32,18 @@ prepare() {
# https://github.com/inste/libtorrent/commit/bdf086234cc6ea07364c6ef20e08c5fc504b70db
patch -uNp1 -i "${srcdir}/fixing-memleak-with-getifaddrs.patch"
sed '/AM_PATH_CPPUNIT/d' -i configure.ac
+ # fix build against openssl 1.1
+ patch -uNp1 -i "${srcdir}"/libtorrent-openssl-1.1.patch
}
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
./autogen.sh
- export CXXFLAGS="${CXXFLAGS} -std=c++11 -fno-strict-aliasing"
+ export CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"
./configure \
--prefix=/usr \
- --disable-debug \
- --enable-ipv6
+ --disable-debug
make
}