summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12023-04-11 16:10:21 +0800
committerChocobo12023-04-11 16:10:21 +0800
commit8923e62d4bca644571cfa298ec9ce7fee0627e6d (patch)
tree2c1a400c25e28e98516d81c502043ce16d94a243 /PKGBUILD
parenta8b00df9e625b4af2539ef6b3c26d4ffd6d5a27b (diff)
downloadaur-libtorrent-rasterbar-1_1-git.tar.gz
upgpkg: libtorrent-rasterbar-1_1-git 1.1.14.r4.g760f94862-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 53b59a379c34..238b1254ac98 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=libtorrent-rasterbar-1_1-git
pkgver=1.1.14.r4.g760f94862
-pkgrel=1
+pkgrel=2
pkgdesc="A feature complete C++ bittorrent library (git branch RC_1_1)"
arch=('i686' 'x86_64')
url="https://www.libtorrent.org/"
license=('BSD')
-depends=('boost-libs')
+depends=('boost-libs' 'openssl')
makedepends=('git' 'boost' 'cmake' 'python' 'python-setuptools')
-provides=('libtorrent-rasterbar')
+provides=("libtorrent-rasterbar=$pkgver")
conflicts=('libtorrent-rasterbar')
options=('!strip')
source=('git+https://github.com/arvidn/libtorrent.git#branch=RC_1_1')
@@ -19,7 +19,10 @@ sha256sums=('SKIP')
pkgver() {
cd "libtorrent"
- git describe --long --tags | sed 's/^[A-Za-z]*[-_]//;s/\([^-]*-g\)/r\1/;s/[_-]/./g'
+ _tag=$(git tag -l --sort -creatordate | grep -E '^libtorrent-1_1_[0-9_]+$' | head -n1)
+ _rev=$(git rev-list --count $_tag..HEAD)
+ _hash=$(git rev-parse --short HEAD)
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^libtorrent-//;s/_/./g'
}
build() {
@@ -27,7 +30,7 @@ build() {
cmake \
-B "_build" \
- -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_INSTALL_LIBDIR="lib" \
-Dpython-bindings=ON \
@@ -40,5 +43,5 @@ package() {
cd "libtorrent"
make -C "_build" DESTDIR="$pkgdir" install
- install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/libtorrent-rasterbar/LICENSE"
+ install -Dm644 "LICENSE" -t "$pkgdir/usr/share/licenses/libtorrent-rasterbar"
}