summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12019-04-17 17:33:58 +0800
committerChocobo12019-04-17 17:52:44 +0800
commit7360bd944d47c0ceae786943ab17940e66f7e991 (patch)
tree46ac92033d5d699aebb1e3a17babba0b0a637985 /PKGBUILD
parent3903b1fdd87468c0437a2a920a8aebe0c46b503c (diff)
downloadaur-7360bd944d47c0ceae786943ab17940e66f7e991.tar.gz
upgpkg: libtorrent-rasterbar-1_2-git 1.2.0.r85.g8506f9350-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 11 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 19131454392a..1e84daf7a9d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=libtorrent-rasterbar-1_2-git
-pkgver=1.2.0.r0.g3a1e546a6
+pkgver=1.2.0.r85.g8506f9350
pkgrel=1
pkgdesc="A feature complete C++ bittorrent library (git branch RC_1_2)"
arch=('i686' 'x86_64')
url="https://www.libtorrent.org/"
license=('BSD')
depends=('boost-libs')
-makedepends=('git' 'boost' 'cmake' 'python' 'python-setuptools' 'python2' 'python2-setuptools')
+makedepends=('git' 'boost' 'cmake' 'python' 'python-setuptools')
provides=('libtorrent-rasterbar')
conflicts=('libtorrent-rasterbar')
options=('!strip')
@@ -23,28 +23,22 @@ pkgver() {
}
build() {
- cd "$srcdir"
-
- mkdir -p "py2" "py3"
- _build 2
- _build 3
-}
-
-_build() (
- cd "py$1"
+ cd "libtorrent"
+ mkdir -p "_build" && cd "_build"
cmake \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_INSTALL_LIBDIR="lib" \
-Dpython-bindings=ON \
- -DPYTHON_EXECUTABLE="/usr/bin/python$1" \
- "../libtorrent"
+ -DPYTHON_EXECUTABLE="/usr/bin/python3" \
+ "../"
make
-)
+}
package() {
- make -C py2 DESTDIR="$pkgdir" install
- make -C py3 DESTDIR="$pkgdir" install
- install -Dm644 "libtorrent/COPYING" "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ cd "libtorrent"
+
+ make -C "_build" DESTDIR="$pkgdir" install
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/libtorrent-rasterbar/LICENSE"
}