summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12020-10-07 12:36:30 +0800
committerChocobo12020-10-07 12:36:30 +0800
commitca66645a405137a8ebcd4c35d5acc4241edd9a31 (patch)
treee290f9ec0b1dbcddf70110f0341097665642dc42 /PKGBUILD
parent614e8183b127cc29f7d988719cab8f592dea708c (diff)
downloadaur-ca66645a405137a8ebcd4c35d5acc4241edd9a31.tar.gz
upgpkg: libtorrent-rasterbar-1_2-git r16640.g89b67d387-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0479805305de..2b67f97f063b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=libtorrent-rasterbar-1_2-git
-pkgver=r16175.g0712c43c6
+pkgver=r16640.g89b67d387
pkgrel=1
pkgdesc="A feature complete C++ bittorrent library (git branch RC_1_2)"
arch=('i686' 'x86_64')
@@ -27,15 +27,15 @@ pkgver() {
build() {
cd "libtorrent"
- mkdir -p "_build" && cd "_build"
cmake \
+ -B "_build" \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_INSTALL_LIBDIR="lib" \
-Dpython-bindings=ON \
-Dboost-python-module-name="python" \
- "../"
- make
+ ./
+ make -C "_build"
}
package() {