summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRobin Nehls2016-01-07 16:24:10 +0100
committerRobin Nehls2016-01-07 16:24:10 +0100
commit9fc63fc7eec5088d189b4553c834147ad3fe7482 (patch)
tree4af26264c556abfffaa7999e43914cd3bd4c15a2 /PKGBUILD
downloadaur-9fc63fc7eec5088d189b4553c834147ad3fe7482.tar.gz
initial
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f3ca31252d63
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Robin Nehls <aur@manol.is>
+
+pkgname=libtpms
+pkgver=0.5.2.1
+pkgrel=1
+pkgdesc="The libtpms library provides software emulation of a Trusted Platform Module (TPM 1.2)"
+arch=('i686' 'x86_64')
+url="https://github.com/stefanberger/libtpms"
+license=(unknown)
+depends=('openssl' 'zlib')
+makedepends=('automake' 'autoconf')
+provides=('libtpms')
+source=("git+https://github.com/stefanberger/libtpms.git#tag=v${pkgver}")
+sha1sums=('SKIP')
+_gitname=libtpms
+
+build() {
+ cd $_gitname
+ ./bootstrap.sh
+ ./configure --prefix=/usr --with-openssl
+ make
+}
+
+package() {
+ cd $_gitname
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim:set ts=2 sw=2 et: