summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaden Kline2018-03-26 22:29:55 -0400
committerCaden Kline2018-03-26 22:29:55 -0400
commit5aee5119b8568956e76f96db61b31866c8ccb6d1 (patch)
treebb702207d2d6456a37aa001f5da3729fac22c1fe /PKGBUILD
downloadaur-5aee5119b8568956e76f96db61b31866c8ccb6d1.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1566427d4078
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Pokemod97 cadenkline9@gmail.com
+pkgname=libtransistor-bin
+pkgver=v1.2.2
+pkgrel=1
+epoch=
+pkgdesc="Nintendo Switch homebrew toolchain"
+arch=('x86_64')
+url="https://github.com/reswitched/libtransistor"
+license=('ISC')
+groups=('base-devel')
+depends=('clang'
+'lld'
+'squashfs-tools'
+'python-elftools'
+'python-lz4')
+makedepends=('git'
+'cmake')
+provides=("libtransistor")
+conflicts=("libtransistor-git")
+replaces=()
+backup=()
+options=(!'strip')
+install=libtransistor-bin.install
+source=("https://github.com/reswitched/libtransistor/releases/download/$pkgver/libtransistor_${pkgver}.tar.gz")
+md5sums=('fc362c1ad0ca99a18e964ab7da7b44f5')
+validpgpkeys=()
+
+package() {
+ mkdir -p "$pkgdir/opt/libtransistor"
+ cp -r * "$pkgdir/opt/libtransistor"
+
+}
+
+
+