summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaden Kline2018-05-16 20:25:17 -0400
committerCaden Kline2018-05-16 20:25:17 -0400
commitd746b39979d2e914ec322c84cbcc821ff203df6a (patch)
tree467ced02acda7c6527f14133bef11f58f4ec5e01 /PKGBUILD
parenta12265f96c663ae20e1972f9e05a5ef5abc7575e (diff)
downloadaur-d746b39979d2e914ec322c84cbcc821ff203df6a.tar.gz
Update for libtransistor base
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f4dee08e56b5..09d7b70d9d39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Mikaela RJ "Qyriad" Szekely <qyriad@gmail.com>
# Special thanks to Pokemod97 for libtransistor-git <3
pkgname=libtransistor-git
-pkgver=1.1.0.r256.g383d582
-pkgrel=2
+pkgver=1.1.0.r328.gd43901e
+pkgrel=1
pkgdesc="Nintendo Switch homebrew toolchain"
arch=('any')
url="https://github.com/ReSwitched/libtransistor"
@@ -18,13 +18,16 @@ makedepends=('git'
provides=("libtransistor")
conflicts=("libtransistor-bin")
options=(!'strip' !'buildflags')
-source=("git+https://github.com/ReSwitched/libtransistor.git#branch=development")
-md5sums=("SKIP")
+source=("git+https://github.com/ReSwitched/libtransistor.git#branch=development"
+"git+https://github.com/reswitched/libtransistor-base.git#branch=master")
+md5sums=("SKIP" "SKIP")
prepare()
{
cd "$srcdir/libtransistor"
git submodule update --init --recursive
+ cd "$srcdir/libtransistor-base"
+ git submodule update --init --recursive
}
pkgver()
@@ -35,8 +38,10 @@ pkgver()
build()
{
- cd "$srcdir/libtransistor"
+ cd "$srcdir/libtransistor-base"
make
+ mv dist "$srcdir/libtransistor/"
+ cd "$srcdir/libtransistor"
}
package()